4

I had a third party company coming over and building ssas databases to produce reports.

They did, but now the DBA wants to have a look but I haven't got permissions, to even see those databases, as you can see on the picture below.

Can I grant myself administrator permissions?

I am system administrator. there is a AD group called SQLDBA and

enter image description here

When right-cliking on the server-properties-security-Add- then adding my AD group SQLDBA it says I don't have the permissions to alter the server object as you can see on the picture below.

I had previously added that sqldba AD group as an administrator to that box.

enter image description here

TITLE: Microsoft SQL Server Management Studio

Either the 'mycompany\MMiorelli' user does not have permission to alter the 'myserver\instance' object, or the object does not exist. (Microsoft.AnalysisServices.AppLocal.Core)


BUTTONS:

OK

  • 1
    right click on the SSAS server node and go to Properties; Security. Are there any names in there? Can you add your name to the list? – DimUser May 15 '18 at 13:56
  • 1
    Try to use "Run as administrator" when running SSMS, it solved the same problem for me – Denis Rubashkin May 16 '18 at 13:04
3

The SSAS permissions are completely independent from SQL Server permissions.

If you don't have permissions, there is one hope:

By default, members of the local Administrators group are also granted administrative rights in Analysis Server. Although the local group is not explicitly granted membership in the Analysis Services server administrator role, local administrators can create databases, add users and permissions, and perform any other task allowed to system administrators. The implicit granting of administrator permissions is configurable. It is determined by the BuiltinAdminsAreServerAdmins server property, which is set to true by default.

Source: https://docs.microsoft.com/en-us/sql/analysis-services/instances/grant-server-admin-rights-to-an-analysis-services-instance?view=sql-analysis-services-2017

I suggest you to read the link above and try to run your Management Studio using an account that is member of Local Administrators group of your SSAS Server

2

from the comments by Denis Rubashkin

Try to use "Run as administrator" when running SSMS, it solved the same problem for me

and that worked for me too.

to run ssms as and administrator press the shift and right click on the ssms icon and that will give the options below:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.