1

I'm going slightly nuts. I'm a programmer by trade - and I only dabble in NT security and DB setup issues.

However, we had a server fail to reboot after a MS Update. I've restored the entire machine from Windows Backup - but I've realized that I cannot rebuild the machine because one cannot realistically use a Windows Backup to restore a database to a different machine, AFAICT. Rather, I need actual DB backups to do that.

In pursuit of having regular SQL Server backups, I'm running into the title error:

[298] SQLServer Error: 15404, Could not obtain information about Windows NT group/user 'WIN-443PT0LULQU\Administrator', error code 0x534

Essentially, I've enabled SQL Server Agent viz SSMS, then I created a management plan to do full backups on our SQL server instance, and scheduled it for daily operations.

However, when I manually ask it to execute that job - to ensure all is working correctly - I get the error:

[298] SQLServer Error: 15404, Could not obtain information about Windows NT group/user 'WIN-443PT0LULQU\Administrator', error code 0x534

That sounds to me like an NT permissions issue - that whatever it is - XP Agent? - attempts to retrieve the permissions of the aforementioned user - and that fails.

Part of what is bizarre here - is there is not machine 'WIN-443PT0LULQU' - that doesn't exist - WTH is SQL Server forcing that in there for in the first place?!

I want this to run as the Administrator - on the local machine 'BUILD-SERVER' - not that garbage name it keeps forcing...

I'm way out of my depth here and this whole process is crazy-making.

How in 2018 is it not possibly to click a few wizard NEXT style buttons and configure Windows / SQL Server to back its freakin' self up regularly correctly?

  • try to troubleshoot it by using sa as the job owner. – Edgar Allan Bayron May 31 '18 at 13:01
1

Okay - after struggling with this for a couple of days (I had tried posting variations on this questions to stackoverflow and to superuser), it seems to be that the SQL Instance had the wrong machine name stored in master - so I had to change that to the correct current machine, and ensure that the correct admin account was enabled as an sa account.

This mostly got me going: http://www.sqlservercentral.com/articles/SQLServer/135372/

I had to do run these to figure out that the instance had the wrong servername, then to drop the bad one, then to add the correct one:

use master
select SERVERPROPERTY('servername')
select @@SERVERNAME
select SERVERPROPERTY('machinename')
go

use master
exec sp_dropserver "WIN-443PT0LULQU\SOURCEGEARVAULT"
go

use master
exec sp_addserver "BUILD-SERVER","local"
go

I also had to mess around with logins - but I cannot say for sure what I did exactly that ended up working. I renamed "WIN-443PT0LULQU\Administrator" to "BUILD-SERVER\Administrator" at one point, and after doing the above, I had to restart the instance.

After that, things seem to be working properly, and I am able to execute my maintenance plan successfully.

  • 1
    Best Practice advice is to use dedicated, non-Administrator, user or users for SQL Server's services. – CaM May 31 '18 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.