0

After opening SSMS, I have found that the master database on one of our production servers is in Single User mode.

Result of select * from sys.databases shows, like SSMS, that the master database has a user_access_desc set to SINGLE_USER.

However, executing sp_helpdb 'master' says it is in MULTI_USER mode.

Nothing problematic noticed on the server. I can access server and master database through multiple threads.

Any ideas?

1

First, Run the

ALTER DATABASE master
SET MULTI_USER;

and confirm you receive the error Option ‘MULTI_USER’ cannot be set in database ‘master’.

Check your errorlog for any information that could explain why and when. Then

  1. Backup the master database
  2. Restore as a different database, example 'master_temp'.
  3. Switch master_temp to MULTI_USER.
  4. Backup master_temp.
  5. Restore master with the backup of master_temp.
  • I was on a call with Microsoft for some other issue and asked them about this problem. Their answer was the same. Thanks. – TheNixon Jun 8 '18 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.