1

For some reason my copy of MySQL Workbench on one of my servers has started adding this --enable-cleartext-plugin option on every mysqldump command, which results in this error every time.

20:13:02 Dumping timesavr_dev (certifications) Running: mysqldump.exe --defaults-file="c:\users\admini~1\appdata\local\temp\3\tmpn1an6u.cnf" --set-gtid-purged=OFF --enable-cleartext-plugin --user=root --host=localhost --protocol=tcp --port=3306 --default-character-set=utf8 --skip-triggers "timesavr_dev" mysqldump: unknown option '--enable-cleartext-plugin'

Operation failed with exitcode 2 20:13:02 Export of C:\inetpub\wwwroot\TimeSavr\DB_Stuff\MySQLBackups\Dump20180608.sql has finished with 1 errors

I just noticed this today but I suspect this started happening a few days ago when some other weird things also happened on this server. After a reboot all the bindings on my website had disappeared, as had the user security privileges on the website folder, and for some reason Shared Config was enabled in my redirection.config file. It all seems very random, and now this.

These are the options I have enabled, and I'm pretty sure these are default because when I click Restore Defaults nothing changes.

enter image description here

How can I tell MySQL Workbench to stop using the --enable-cleartext-plugin option?

1

"Enable Cleartext Authentication Plugin" is a connection setting, not a setting of "Data Export".

You can find it under "Database", "Manage Connections", here select your connection; inside the "Connection"-tab is the "Advanced"-tab with a checkbox to (un-)select that option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.