1

I'm trying to install latest version of PostgreSQL and the install keeps running into the problem of

Error running the Post-Install Step. Installation may not complete correctly. The data cluster initialization has failed.

I looked online and found a lot of solutions to the problem and I've tried most of them. However, I keep getting the same error, so I looked at the Install-Log and it say that Icacls doesn't exist, which seems new.

Called IsVistaOrNewer()...

'winmgmts' object initialized...

Version:10.

MajorVersion:10

Ensuring we can write to the data directory (using icacls) to CORPORATE\pjy002:

Executing batch file 'radC235D.bat'...

'icacls' is not recognized as an internal or external command, operable program or batch file.

Some other important things.

  • Downloading PostgreSQL on a virtual machine

  • Am an administrator of said virtual machine or at least can get adminrights

  • Using Windows 10

  • Installing PostgresSQL 10.4

  • It looks as if you are running the installer as a domain user - try to run it with a local administrator account of that machine (not a domain account). I assume you are talking about the EnterpriseDB installer? You might want to try the installer from 2ndQuandrang maybe that works better with a domain account. – a_horse_with_no_name Jun 19 '18 at 12:40
  • You can also try a manual installation using the ZIP binaries: See here stackoverflow.com/a/4974170 or here: stackoverflow.com/a/4256125 – a_horse_with_no_name Jun 19 '18 at 12:44
  • Cool, I'll try those things and see if they work. – Peter Jun 19 '18 at 13:07
  • I've tried the things you're talking about (except running it with an administrator account - need to get approval for that). 2ndquandrang seems to be getting close but I can't open up the application. I've tried the Manual installation but I keep getting the same error message. – Peter Jun 19 '18 at 14:05
  • Nowhere in the "manual installation" are you required to run icacls (which is a standard Windows command line tool - I am very surprised that it's not available on your computer) – a_horse_with_no_name Jun 19 '18 at 14:10
0

Figure out the problem. Had to get elevated rights and then install it. Thanks to everyone that helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.