4

I get an odd problem in my SQL R2. Although I can attach a new db to my db instance, but all buttons on the tool menu panel are disabled. So I cannot execute any sql query statements. It is really annoying !!! I have been stuck on it for ages.

Could someone help me figure it out?

All buttons disabled

Thank you so much.

5
  • 1
    Yes you can. Click New Query and a new query window should open up. Then you can execute your SQL query. As for the grayed out buttons, your object explorer is already connected, which is why I'm guessing those buttons are disabled. Regardless, you shouldn't be prohibited by that screenshot. Jul 17, 2012 at 14:00
  • @Shark, thank you for your timely reply. I have tried to click "New Query", it did pop up a new query window, but all buttons remain disabled.
    – Franva
    Jul 17, 2012 at 14:07
  • You need to have an actual query window open in order to be able to click "Execute." You can do this by clicking the New Query button or by right-clicking the server and choosing New Query. Jul 17, 2012 at 14:08
  • @Franva can you show a screen shot that includes your cursor in the New Query editor window and the Execute button is still disabled? Not that I don't believe you, but... Jul 17, 2012 at 14:08
  • @Aaron Bertrand, Hi Aaron, thank you for your reply. I am not a beginner in SQL. I did try open a new query window and selected my query statement. Execute button still remains disabled. I am running a repair program, will show you the screenshot in 2 mins.
    – Franva
    Jul 17, 2012 at 14:13

3 Answers 3

3

I have found the solution for this issue.

Simply go to Start -> Microsft SQL Server 2008 R2 -> Configuration Tools -> SQL Server Installation Center (64-bit)

Then go to the Maintenance option -> Repair.

Done.

1

I had the same issue where my Execute button was disabled. Somehow I save the sql files I was wanting to execute as .txt files. When I changed to .sql files the 'Execute' button was enabled and I could continue with my tasks. I hope this helps.

1

Just experienced this and I had to shut down SSMS, once I did it gave me a warning a dialog was open, but I didn't have any open... Shutting it down and restarting it fixed the issue. If SQL doesn't get a response back it won't enable the execute button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.