2

I did see that it supports SQL Server (2005 and later) but does it support syncing between a SQLExpress server or MySQL server and an Azure Server?

I'm trying to use it with a SQLExpress server but it isn't connecting. Is this because it's not supported?

The error I'm getting when trying to connect with SQL Data Sync 2.0 on my server computer is: Unable to connect to the Database. Please check if service account has connectivity, credentials, and permissions to connect.

I've opened up port 1433 in the firewall and can connect to the server via SSMS. However, the SQL Data Sync 2.0 application won't connect.

I'll be trying this with a MySQL server later as well so I just wanted to know if it's supported or not as well.

  • 1
    Please provide connecting error if there is any. Azure SQL Data Sync service built on Azure SQL Database that lets you synchronize the data you select bi-directionally across multiple SQL databases and SQL Server instances. I do not think it matters what edition of SQL Server. MSDN do not mention any edition limitations either – samosql Jun 26 '18 at 19:55
  • The error I'm getting when using SQL Data Sync 2.0 reads: 'Connection failed. Please check database credentials along with permissions for Microsoft SQL Data Sync Windows service log on account to connect to database with specified credentials.' I'm trying to log in with SQL authentication and I definitely have the right credentials for that. – Goalaso Jun 26 '18 at 21:42
0

Azure SQL Data Sync does not support MySQL for synchronization but it does support SQL Server Express as you can read here.

One of the troubleshooting steps is to exit local sync agent, then open the services.msc applet in Control Panel, make sure SQL Data Sync service is started, if the service is started please restart the service. If the service cannot start change the service account to a local Administrator of the computer. Reopen the local sync agent.

Try also to disable any security software (Avast, Windows Firewall). Start SQL Server Browser Service on the computer.

Another possible reason, the agent key that you have entered is invalid. The agent key being submitted is not the most recent; you may have regenerated a newer key on Azure Sync portal. Try regenerating on Azure portal and resubmitting.

  • Thanks for this answer. I tried everything you said and it all didn't work. However, I tried installing the developer version of a SQL Server (not express) onto the server computer as well, which in turn enabled SQL Server Browser service. On SQLExpress, the Server Browser is disabled. Now, I can connect to both SQL and SQLExpress servers using the data sync. – Goalaso Jun 27 '18 at 16:32
  • SQL Server Browser is important for successful connection to named instances, and SQL Server Express by default is installed as named instance. Thank you for letting us know which one of the possible causes was the culprit. Have a wonderful day! – Alberto Morillo Jun 27 '18 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.