Error message:

You do not have privileges to manipulate with the users!

Appears in PhpMyAdmin using Mariadb 10.3.7 on MacOs High Sierra installation from Homebrew

I'm logged in as root installed and rebooted with multiple server options: Mysql 5.7, Mysql 8.0 Mariadb 10.2 and 10.3.7.

I've tried everything from granting tables, flushing the permissions. I need to be able to edit users from the PhpMyAdmin page and its not allowing me even though I have root access (with password set)


According to comments in this Github issue report for phpMyAdmin, you probably need to set this option:

$cfg['Servers'][$i]['DisableIS'] = true;

in config.inc.php. Though it sounds like this is a workaround for a bug, so may be fixed in later releases or not an issue in earlier releases.

| improve this answer | |

I solved it by changing my control user to 'root' and then logging in with phpMyAdmin as 'root'. That seems overly simplistic, but it worked.

| improve this answer | |
  • Thank you for your answer. However I would rather not have a control user as root if I can help it since it creates a huge security hole. – Danny F Jun 23 '19 at 0:00

See fix and patches here at phpmyadmin:


| improve this answer | |

simply use chrome browser and you won't face this problem.

Open your phpmyadmin in chrome and you are good to go!!

You will have this problem in internet explorer but not in chrome.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.