2

Error message:

You do not have privileges to manipulate with the users!

Appears in PhpMyAdmin using Mariadb 10.3.7 on MacOs High Sierra installation from Homebrew

I'm logged in as root installed and rebooted with multiple server options: Mysql 5.7, Mysql 8.0 Mariadb 10.2 and 10.3.7.

I've tried everything from granting tables, flushing the permissions. I need to be able to edit users from the PhpMyAdmin page and its not allowing me even though I have root access (with password set)

2

According to comments in this Github issue report for phpMyAdmin, you probably need to set this option:

$cfg['Servers'][$i]['DisableIS'] = true;

in config.inc.php. Though it sounds like this is a workaround for a bug, so may be fixed in later releases or not an issue in earlier releases.

1

I encountered this recalcitrant problem in Ubuntu after upgrading MySQL despite 'uninstalling' it. The problem is that the mysql schema is retained at /var/lib/mysql and the upgrade changes the number of columns in the user table. It seems that as a safety measure, the installer alters the permissions on the phpMyAdmin administrator (and even root). If this is your problem (examine the user table in the mysql schema in the mysql command-line console) then fix each flag along the lines of:

UPDATE mysql.user SET Grant_priv = 'Y' WHERE user = 'phpmyadmin' AND host = 'localhost';

You'll need to do this for every affected privilege.

2
  • I don't think it's such a good idea to manipulate system tables directly. Wouldn't issuing the corresponding GRANT statements be safer?
    – mustaccio
    Dec 20 '20 at 17:06
  • Uhh, the whole point was that the GRANT statement wasn't working because of the 'conservative corruption' of the table! A bit of a pickle, until you work out that the UPDATE still works :) I describe the issues further in a post on Medium: dr-jo.medium.com/the-fourth-circle-a2831bbdf769 Dec 22 '20 at 0:31
-1

I solved it by changing my control user to 'root' and then logging in with phpMyAdmin as 'root'. That seems overly simplistic, but it worked.

1
  • Thank you for your answer. However I would rather not have a control user as root if I can help it since it creates a huge security hole.
    – Danny F
    Jun 23 '19 at 0:00
-2

See fix and patches here at phpmyadmin:

https://github.com/phpmyadmin/phpmyadmin/issues/14433#issuecomment-544249375

0
-2

simply use chrome browser and you won't face this problem.

Open your phpmyadmin in chrome and you are good to go!!

You will have this problem in internet explorer but not in chrome.

1
  • if you think I use IE you have to be daft
    – Danny F
    Apr 20 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.