I joined a company as a fresher DBA and in testing server there is weird problem.

My listener is running very well and developers can connect remotely to database but whenever I tried to start enterprise manager it shows me error like:

Listener status down. The listener "(Listener name)" is not running using the Listener parameter file: "D:\app\dbadmin\product\11.2.0\dbhome_1\network\admin/listener.ora" on Host: "(Hostname)" at Port: "1521".

When I write emctl status dbconsole it shows me:

C:\Windows\system32>emctl status dbconsole Oracle Enterprise Manager 11g Database Control Release Copyright (c) 1996, 2010 Oracle Corporation. All rights reserved. https://(HOSTNAME):5500/em/console/aboutApplication Oracle Enterprise Manager 11g is running.

Logs are generated in directory D:\app\dbadmin\product\11.2.0\dbhome_1/(Hostname)_(Listenername)/sysman/log

Here is my listener.ora file:

(Listener Name) =
      (ADDRESS = (PROTOCOL = TCP)(HOST = (Hostname))(PORT = 1521))

lsnrctl status:

 LSNRCTL for 64-bit Windows: Version - Production on 10-JUL-2018 14:33:08

Copyright (c) 1991, 2010, Oracle.  All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
Alias                     LISTENER
Version                   TNSLSNR for 64-bit Windows: Version - Production
Start Date                02-JUN-2018 19:18:22
Uptime                    37 days 19 hr. 14 min. 57 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   D:\app\dbadmin\product\11.2.0\dbhome_1\network\admin\listener.ora
Listener Log File         d:\app\dbadmin\diag\tnslsnr\ESTDEV03\listener\alert\log.xml
Listening Endpoints Summary...
Services Summary...
Service "********" has 1 instance(s).
  Instance "*******", status READY, has 1 handler(s) for this service...
Service "******" has 1 instance(s).
  Instance "******", status READY, has 1 handler(s) for this service...
The command completed successfully.


TNS Ping Utility for 64-bit Windows: Version - Production on 13-JUL-2018 10:16:01

Copyright (c) 1997, 2010, Oracle.  All rights reserved.

Used parameter files:

Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = (Service Name))))
OK (20 msec)


# tnsnames.ora Network Configuration File: D:\app\dbadmin\product\11.2.0\dbhome_1\network\admin\tnsnames.ora
# Generated by Oracle configuration tools.

(Listener Name)=
    (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
      (SERVICE_NAME = (service name))

(Listener Name) =
  (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

I asked old DBA but he was not able to find a solution.
So can you please tell me where is a problem?

  • give us the output of "lsnrctl status" on the listener itself Jul 10, 2018 at 8:28
  • @AndrewBrennan I added it in question.
    – Chris Pop
    Jul 10, 2018 at 10:37
  • OK it's not that. Might be a bug to do with windows file names - note the forward slash in the error message that isn't in the listener config Jul 10, 2018 at 13:38
  • @AndrewBrennan i also noticed that, is there any way to change that slash?
    – Chris Pop
    Jul 11, 2018 at 5:15
  • 1
    Your lisetner.ora looks odd lsnrctl status shows hosts as ESTDEV03 and localhost(127.0.0;1) and yet listener.ora shows "HOSTNAME"?.Multiple instances on same host?.If muliple instance set enviornment varibales properly.Check in ORACLE_HOME for directory either or ESTDEV03_SID (SID is your %ORACLE_SID%).Let me know if that directory exists.Always set environmental variables before running emctl/emca commands(set ORACLE_UNQNAME=%ORACLE_SID% and Set ORACLE_SID=%ORACLE_SID%).
    – user153556
    Jul 12, 2018 at 15:51

1 Answer 1


Try resetting the local agent:

> emctl stop agent

> emctl clearstate agent

> emctl start agent
  • Did it but nothing happened. It still shows an error.
    – Chris Pop
    Jul 11, 2018 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.