0

I have recently installed Oracle XE 11 on my local machine and then installed SQL Developer. But when I try to create a new connection (for my localhost) or add from 'database detected local XE' it returns either ora-12514 or ora-12505. I know the password that I entered during the installation.

  • OracleXETnsListener,OracleServiceXE service is running
  • Tried connecting via localhost, 127.0.0.1 and computer_name
  • Opened localhost tns and wrote the information there

But I am still not able to connect.

It bugs me that even a simple localhost connection is problematic when it comes to Oracle tools. It should be as easy as using Microsoft tools. I can't even connect to a localhost xe oracle.

What is wrong?

Edit: I may have found the issue.. I have installed Oracle XE 11.2 as domain user so probably there is some other configuration that needs to be done to access.?

1

ORA-12514 means there is no requested service registered in the listener.

ORA-12505 means there is no requested instance registered in the listener.

If the service name or instance name you provided was correct, then your database may be not started.

Oracle databases run as a service on Windows named OracleServiceXE (for Express Edition), you should check and start the service if it is not running.

On Linux, you can start the database as:

sqlplus / as sysdba
SQL> startup

After that you should see your instance and services in the output of lsnrctl status, and that is when you should try connecting again.

  • I think i have found the issue but dunno how to solve.. I installed oracle xe 11.2 as domain user.. do i have to install it as different user? What is tns or configuration for domain user access even it is local – Mert Serimer Jul 13 '18 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.