0

i am trying to create a new database along with another database. The server already has a database running. I used DBCA command to create the new db instance. First i set the new SID and home and then ran the dbca command.. But half way through installation im getting the error

ORA-01503 CREATE CONTROLFILE FAILED

ORA- 01158: database already mounted

  • Either that file exists or you have permission issues. What are your control files as defined in your init.ora? – sandman Jul 18 '18 at 8:06
0

First of all, you could check the newly created init/spfile (under; linux: $OB/dbs - or - win: $OB\database) if everything is set correctly (SID and Service Name, Datafile location...)

I also would advise you to check all your env. vars, the error says “Database already mounted” - it seems it’s trying to create a .ctl for your already-running database.

You can try this to start fresh;

Linux

  • copy your actual .profile in .profile_new
  • modify .profile_new as per your need ($OH, $ORACLE_SID,...)
  • ./profile new
  • check you’re all set: env
  • start dbca again

Windows

  • open cmd as Admin
  • set ORACLE_SID=[your new SID]
  • set ORACLE_HOME=[your new $OH]
  • run dbca

Last thing, i would take a look at the oraInventory/oraInst.lok file, to check if there’s the old $OH set - if yes, move the file away (just to backup it) and restart the dbca.

Hope one of this solutions helps.

  • Thanks a lot ..it worked now....when i got this error first ..i tried creating another database...so the error kept coming ...When i checked i saw, eventhough the installation failed with this error ,the database got created ..So i used DBCA to delete the created database ...and set the env properly...then it worked – arun Jul 25 '18 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.