0

Searching around I found a lot of thread about this problem (coming from 2012) but I can't find an official solution: running cqlsh.bat

  File "C:\apache-cassandra-3.11.2\bin\\cqlsh.py", line 146
    except ImportError, e:

The error suggests the script is for python 2. In system environment I have python3, there is a Cassandra version compatible or there is an official fix for this?

  • No, cqlsh still requires Python2 – Alex Ott Feb 12 at 1:19
0

I had the same problem as you. I had installed python 2.7 version as mentioned at Prerequisites and the error no longer appears

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.