I've created a new catalog (case insensitive, make default catalog), when I try to right click > properties to add tables I get this error:

Property PopulationStatus is not available for FullTextCatalog '[Search]'. This property may not exist for this object, or may not be retrievable due to insufficient access rights. (Microsoft.SqlServer.Smo)

Executing this code I found I get NULL


When I right click on tables the Full-text index is grayed out...

What am I missing? How can I fix this?

4 Answers 4


I found out that even if it is not installed it is still available on SQL Server Management Studio and you can create the indexes. It shouldn't allow...

Then I found this: SQL Server 2008 R2 Express - Installation Options, to allow FTS I need the 800MB version...

To check the status of FTS I found these queries:

FROM sys.fulltext_catalogs AS cat

SELECT fulltextserviceproperty('IsFulltextInstalled')

I had exactly the same issue. Upon investigation I found that full text indexing was not installed on the machine.

Please note even if Full text indexing is not installed - SQL management studio will still show the option and strangely allow you to even create a full text index.

I got the original instal files - add selected the option of adding features to an existing installation.

The check box for full text was unticked. I ticked it and ran the install.

All was working after that.

Kind Regards Sandeep

  • Yes, this was it! Didn't have full text search installed.
    – Scott
    Commented Sep 20, 2012 at 13:00
  • It is quite misleading that it appears as an option and allows you to create the placeholder in SQL Management Studio.
    – RacerNerd
    Commented Mar 19, 2014 at 20:16
  • Yes, that was the issue. It worked after enabling this feature from setup. Thank you
    – Tayyab Ali
    Commented Feb 15, 2023 at 6:32

I've been getting the same error on both of my development machines. I could never get the upgrade install to work though because Full-Text Search wasn't on the feature list. Finally what did work was extracting the exe and running:


After that runs go back into the upgrade screen and the Full-Text Search option should now show in the feature list.


I had a similar problem as well. Where mine differs is I was originally running SQLEXPRESS and installed the full version on top of it to get full text functionality. After the install my SSMS console showed the Storage node so I thought I was in the clear.

When accessing it I was getting the above error. The fix was to detach my old database from the original SQLEXPRESS instance and reattach it to the full SQLSERVER instance.

Not sure if this relates to your problem but I came across this question searching for an answer to my own problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.