Please follow the logic of my attempts at upgrade before suggesting a fix. The error 443 is not the main problem here.

  • we are upgrading from oracle to on a Solaris 11.3 server 'test'.
  • all upgrades are successful except the one database called VIT which throws the error on startup upgrade (after logging in as oracle12): terminating the instance due to error 443
  • we cloned VIT and mounted it on another server. It upgrades successfully. We then mounted the same clone on 'test' and it does not startup, throwing the same error 443.
  • we then renamed VIT to VITNEW on 'test' and the upgrade works! We then renamed it back to VIT and it throws the same error 443 on startup.

So after all these attempts it's obvious to me that there is either something with the name or the server, but bear in mind other databases work on that same server, and it's ONLY that name of VIT that does not work on 'test'.

Weird problem. We have opened a SR for it, but Oracle have no answers yet. Hoping someone might have an idea.

  • Does pmon generate a trace file anywhere? Check the memory settings for the instance in the (s)pfile, you may be running out of memory.
    – Philᵀᴹ
    Commented Jul 30, 2018 at 9:31
  • Nothing more in the trace file than PMON died: terminating the instance due to error 443. We have 150G of free memory on that server so that's not the issue. We also looked into shared segments not clearing, and bounced the server. Same issue.
    – sandman
    Commented Jul 30, 2018 at 9:37
  • 1
    Besides, we renamed it to VITNEW and the upgrade works... so it's NOT the typical memory issues associated with error 443
    – sandman
    Commented Jul 30, 2018 at 9:39
  • Is the oracle12 user new to your environment? Was that user used to perform the upgrades to your other databases, as well as for installing the 12.2 software?
    – John A
    Commented Jul 30, 2018 at 15:06
  • 1
    @MarkStewart: what's weird is that any other name works, including 3 or 4 character names. I'm thinking there is a file lock of some sort associated with that name (similar to /var/tmp/.oracle socket locks) but I can't find where
    – sandman
    Commented Jul 31, 2018 at 7:16

1 Answer 1


We got to the bottom of this eventually!

It was an oracle group write (g+w) permission missing in the parent folder of the diagnostic_dest structure. Why it gives an error 443 and not a simple write permission error, only the oracle engineers who created this enigmatic diagnostic_dest structure will know!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.