1

So, I've been trying to solve the blue icon question mark on my sql server in SQL Server Management Studio by following the answer in the following link:

Blue icon with question mark - what does it mean?

after executing the above recommended answer I was still unable to resolve this question mark icon issue and to prove that it was related to the WMI I followed these steps:

  1. In windows Start > Run > WBEMTest

  2. Type the following under namespace \\NameOfMyServerOrMachine\root\Microsoft\SQLServer\ComputerManagement13

  3. Click on "Query..."

  4. Enter Query Select * from SQLService and Apply

  5. I get 0 rows

What does this mean? what else am I missing?

This is what I have tried so far:

  1. Added my windows user to the Distributed COM Users and Performance Monitor Users
  2. in my sql server machine, I opened the WMI Control and gave permissions to group Performance Monitor Users so that they could have Enable Account and Remote Enable access to the namespace and subnamespaces on : \\NameOfMyServerOrMachine\root\Microsoft\SQLServer\ComputerManagement13
  3. Verified that the WMI service is running in the sql server machine
  4. TCP Port 135 is enabled and open in the guest machines
  5. Windows Management Instrumentation (DCOM-In) and Windows Management Instrumentation (WMI-In) Inbound rule is enabled in the guest machines firewall.

Any thoughts?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.