Apologies in advance for lack of information. I have installed MySQL 5.5 x64 on a Windows XP Professional x64 development machine. Today, upon trying to connect with any tool(MySQL workbench, PHP script, PhpMyAdmin, or command-line utility), the password is accepted but the connection is immediately closed:

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysql -u root -p
Enter password: ***************
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 4
Server version: 5.6.5-m8 MySQL Community Server (GPL)

Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> Bye

C:\Program Files\MySQL\MySQL Server 5.6\bin>

I have attempted removing all MySQL server-related files by deleting the installation directory and C:\Documents and Settings\All Users\MySQL\MySQL server 5.6, as well as D:\InnoDB Datafiles, where my InnoDB Tablespace lies. There is no important data, but I am unable to get MySQL server to operate properly. If any more info is needed, please do tell.

I have installed MySQL with the MSI installer and the instance config wizard. I have also tried the 5.6 development version, to no avail.

migrated from serverfault.com Jul 24 '12 at 20:13

This question came from our site for system and network administrators.


A) Try with

  • mysql -h[your IP] -u[username] -P[]port -p
  • mysql -h127.0.0.1 -u[username] -p
  • mysql -hlocalhost -u[username] -p

Which one works and which does not?

B) Set Log_warnings=2 in my.ini and restart MySQL server and see error log entry when connection gets closed abruptly.

  • Even with that option in my.ini there is no added data in the Windows event log or C:\Program Files\MySQL\MySQL Server 5.6\data\[computername].err. If it helps, I don't really care about the data as it's a dev machine and I have my schema ready as an SQL script, but I do need a working server. – ζ-- Jul 25 '12 at 11:46
  • I think you can report to bugs.mysql.com if you are able to replicate this situation everytime. – Mahesh Patil Jul 25 '12 at 12:04
  • I'm not trying to report a bug, but I'm trying to get up and running again. Thanks anyway. – ζ-- Jul 25 '12 at 12:11
  • I have tried 5.5 to no avail. Also, I need InnoDB fulltext search for the project I am developing. – ζ-- Jul 25 '12 at 12:34
  • InnoDB Fulltext search is supported in v5.6 only dev.mysql.com/tech-resources/articles/… , You should try it,only thing is it's in development phase and stable release may take few months – Mahesh Patil Jul 25 '12 at 12:38

Have you looked in the Windows event log to see if mysql is reporting any errors?

Also, do you permit root logins?

Final thing to look at.. you are logging to your loopback address (, which in recent memory caused some issues in XP. Try using your ip address instead.

  • Actually, it states: Cannot find or open table mysql/innodb_index_stats from the internal data dictionary of InnoDB though the .frm file for the table exists. Maybe you have deleted and recreated InnoDB data files but have forgotten to delete the corresponding .frm files of InnoDB tables, or you have moved .frm files to another database? or, the table contains indexes that this version of the engine doesn't support. in event log... Also, I am logging on as root as it's a dev machine... – ζ-- Jul 24 '12 at 19:37
  • 1
    ok, then if that is the issue and a fresh install, why don't you try running mysql_install_db.exe and do a fresh instance install and have a fresh data dictionary. good short reference: kb.askmonty.org/en/mysql_install_dbexe/5551 – dwgranth Jul 24 '12 at 19:43
  • I don't have such an executable in C:\Program Files\MySQL\MySQL Server 5.6\bin, but I have performed a full installation. The link you gave applies to MariaDB. – ζ-- Jul 24 '12 at 19:45
  • I have InnoDB and MyISAM engines, not MariaDB. – ζ-- Jul 24 '12 at 19:58
  • Similar utilities.. sorry :). Your my.ini has a basedir="C:\Program Files\MySQL\MySQL Server 5.6" and datadir="C:\InnoDB Datafiles" in it? Did you move the files after you fired MySQL up? – dwgranth Jul 24 '12 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.