-1

I can no longer start sql-server on antergos linux. This is what I tried so far (following this link):

$ sudo systemctl status mssql-server.service
● mssql-server.service
   Loaded: bad-setting (Reason: Unit mssql-server.service has a bad unit file setting.)
   Active: inactive (dead)

$ sudo -u mssql /opt/mssql/bin/sqlservr -m SQLCMD
/opt/mssql/bin/sqlservr: The file archive [/opt/mssql/lib/system.sfp] is invalid.  Please resolve and try again.

$ sudo ls /var/opt/mssql/log | grep .mdmp
(nothing)

$ sudo ls /var/opt/mssql/log | grep .tar.gz2 
(nothing)

more over, I had a look a this document, and I tried to find the unit file of mssql service.

$ sudo ls -la /usr/lib/systemd/system/mssql-server.service 
-rw-r--r-- 1 root root 655 ago 11 01:44 /usr/lib/systemd/system/mssql-server.service

Then I tried to open it with sublime-text or nano, but it seems to contain binary content, sublime-text show several columns filled with 0000. I guess this is what systemd is talking about when it says that the service has a bad unit file setting.

Here goes some context

$ pacman -Q | grep sql
msodbcsql 17.2.0.1-1
mssql-server 14.0.3030.27-1
mssql-tools 17.2.0.1-1
sqlite 3.24.0-1

$ uname -a
Linux antergos 4.17.14-arch1-1-ARCH #1 SMP PREEMPT Thu Aug 9 11:56:50 UTC 2018 x86_64 GNU/Linux

Is there something else I could try before reinstalling everything?

0

Community wiki answer:

Doesn't look like Antergos is on the list of officially supported Linux OSes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.