1

I'm using Ubuntu 16.04 and MongoDB 4.0.1. When I use mongo shell I got this :

I STORAGE  [initandlisten] 
I STORAGE  [initandlisten] ** WARNING: Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
I STORAGE  [initandlisten] **          See http://dochub.mongodb.org/core/prodnotes-filesystem
I CONTROL  [initandlisten] 
I CONTROL  [initandlisten] ** WARNING: Access control is not enabled for the database.
I CONTROL  [initandlisten] **          Read and write access to data and configuration is unrestricted.
I CONTROL  [initandlisten] 

So I read lot of threads about this problem but nothing works... I created my users as it said here and login with my created users but I got again the same warnings.

I don't have created the data/db folder. I don't know if it's necessary in 4.0.1 version. It's confused for me. Inside my mongod.conf I got this :

storage:
  dbPath: /var/lib/mongodb

Should I let this config or should I rename to :

storage:
  dbPath: /data/db

I don't know what to do. Can you help me please ?

  • Have you enabled authentication in your config file and restarted mongodb server? Also is /var/lib/mongodb is mounted on XFS based partition? – Kapil Bhagchandani Aug 22 '18 at 10:00
  • Yes I just remember to enable security authentication in the config file. But I don't understand why people don't mention to do this. It's so important... I'm becoming mad. So I don't have any warning now it works. But I don't understand why XFS warning is gone ? O_o – John Aug 22 '18 at 10:07
  • let me know if your problem is resolved. If not then please share your config file and the output of df -h command – Kapil Bhagchandani Aug 22 '18 at 10:11
  • It's resolved. But can you tell me if it's necessary to change my dbpath and create the /data/db folders ? – John Aug 22 '18 at 10:14
  • I don't feel it is needed. – Kapil Bhagchandani Aug 22 '18 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.