0

I'm trying to set up a dummy mongodb server on my local device so I can play around with it and make mistakes so that I can feel confident editing the actual server. I use the following code to start the mongodb server:

 sudo service mongod start

However executing sudo service mongod status outputs the following:

   ● mongod.service - MongoDB Database Server
       Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Wed 2018-08-29 15:46:44 ACST; 754ms ago
         Docs: https://docs.mongodb.org/manual
      Process: 14604 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=exited, status=62)
     Main PID: 14604 (code=exited, status=62)
          CPU: 1.889s

    Aug 29 15:46:42 david-Aspire-A515-51G systemd[1]: Started MongoDB Database Server.
    Aug 29 15:46:42 david-Aspire-A515-51G mongod[14604]: 2018-08-29T15:46:42.435+0930 I CONTROL  [main] Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'
    Aug 29 15:46:44 david-Aspire-A515-51G systemd[1]: mongod.service: Main process exited, code=exited, status=62/n/a
    Aug 29 15:46:44 david-Aspire-A515-51G systemd[1]: mongod.service: Unit entered failed state.
    Aug 29 15:46:44 david-Aspire-A515-51G systemd[1]: mongod.service: Failed with result 'exit-code'.

Tried adding sudo service mongod start --sslDisabledProtocols 'none' to no avail. Any help would be much appreciated

0

Running following code in terminal fixed my issue for error 62:

mv /var/lib/mongodb /var/lib/mongodb_backup
mkdir /var/lib/mongodb
chmod 700 /var/lib/mongodb
chown mongodb:daemon /var/lib/mongodb
systemctl restart mongodb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.