1

We recently upgraded from SQL 2016 SP1 build 4466 to SP2 build 5201 (CU2 GDR) on an AG.

On one server an analyst was deploying SSIS using Visual Studio Enterprise 2015 (version 14.0.25431.01 Update 3 and MS. NET framework 4.7.02558).

Since the SQL upgrade they get this error message:

Failed to deploy project. For more information , query the operation_messages view for the operation identifier '777'. (Microsoft SQL Server, Error: 27203)

Querying the operations_messages table in the SSISDB database for 777 I get this message:

Failed to deploy the project. Fix the problems and try again later.:Cannot use SAVE TRANSACTION within a distributed transaction.

That message appeared as fixed in SP2 CU1 in this KB https://support.microsoft.com/en-us/help/4092554/fix-cannot-use-save-transaction-within-a-distributed-transaction-when

The analyst says she gets the same error if she uses Management Studio and the IS Deployment Wizard.

6
  • Just to confirm - based on version numbers, it looks like you have SP2 CU2, with the GDR patch. Hence, your note that the problem was reported fixed in CU1. Correct?
    – RDFozz
    Commented Sep 10, 2018 at 19:27
  • YES we wanted the benefits from SP2 CU1 and CU2 and also ptotection against CVE-2018-8273. The analyst says she gets the same error if she also uses Management Studio and the IS Deployment Wizard
    – user93150
    Commented Sep 10, 2018 at 19:39
  • Seems that we can deploy if we drop the SSISDB database from being in an AG. The description of the problem in the KB seems to be what is happening
    – user93150
    Commented Sep 12, 2018 at 16:43
  • Looks like this is the same as support.microsoft.com/en-ca/help/4092554/… because we changed the AG to drop the WITH DTC_SUPPORT = PER_DB and now it works.
    – user93150
    Commented Sep 13, 2018 at 19:37
  • If you've found an answer to your problem, you can post the answer yourself. There may be a delay before you can accept your answer (although, since you posted the question several days ago, you'll probably be able to accept it right away). And, congrats on a solution!
    – RDFozz
    Commented Sep 13, 2018 at 20:12

1 Answer 1

0

Seems that changing the AG to not have WITH DTC_SUPPORT = PER_DB works. Microsoft have been informed. Looking forward to a fix in a future SP2 CU.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.