I am following the SSAS Tabular Model Tutorial by Microsoft using the Adventure Works DW. I've imported the DW in SQL Server Management Studio to my local server. I've connected to the DW from Visual Studio, everything worked fine, completed all the steps of the tutorial until deployment. Building the Model works just fine, however when I try to deploy the Model it throws me the error

Error Cannot deploy metadata. Reason: An error occurred while connecting to the server. 0

error message

Some other users have also reported the same issue and could solve it with reinstalling SSDT, tried that, did not work for me.

Any ideas would be very much appreciated!

  • What credentials are you using to deploy the model, and does this account have the necessary permissions on the SSAS instance?
    – userfl89
    Oct 1, 2018 at 15:30
  • I used the Windows Credentials in Impersonate Account mode. where would I see if this account has permissions on the SSAS instance? in SSMS?
    – julmoser
    Oct 2, 2018 at 11:56
  • You can see accounts that have role membership in the Roles folder of a model when connected to SSAS in SSMS, however if you're using your Windows credentials you're likely in the local Administrators group and have the necessary privileges. Have you confirmed that the deployment server name is correct?
    – userfl89
    Oct 2, 2018 at 14:10
  • Yes I set the deployment server in SSAS name like it is in SSMS server properties
    – julmoser
    Oct 2, 2018 at 15:14

3 Answers 3


I got the same error. After doing some research I changed the server name and that worked.

Go to your Solution explorer > Project > Properties. Change server name from Localhost to the actual server name.

SSAS Project Properties


I just found out why I could not deploy my Tabular model to the server:

I tried to deploy it on the SQL Server (where my source DW is located), but obviously the Tabular Model needs to be deployed on the Analysis Server

  • can you tell more about the solution? I'm having the same issue. Some screens would be apprecieated.
    – user175217
    Mar 21, 2019 at 19:22

On the solution properties, identify the server as a tabularmodel ie ... localhost\tabularmodel. This is what worked for me.

  • 2
    Welcome to DBA.SE. Is there any chance you could post a screenshot of your solution? This would help others. Currently your answer popped up in the Very Low Quality - Review Queue as it doesn't contain a wealth of information. Just wanted to let you know. If anybody else in the community with enough reuputation reviews your answer, they might deem it to be of low quality and it might be auto-deleted. Thanks. See How to Answer for more information.
    – John K. N.
    Jan 21, 2021 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.