1

I have the environment that I explain below and I need to encrypt the data that is sent between my two nodes, I have been reading but I can not find the right solution, I explain: I have an Oracle Database 12c in which I have Advanced Security implemented through the netmgr but the encryption between the databases does not work, when putting a capture of the packages with tcpdump is shown in plain text when I use dblink, these dblinks are they use to load information from different sources (Oracle, PostgreSQL and SQL Server ... the latter using Oracle Gateway). How can I encrypt the communication between the source and the destination and vice versa to use the dblinks? Thank you very much.

  • How do you encrypt your Data? SQLnet native or via TLS? Can you post your sqlnet.ora? – jmk Sep 30 '18 at 7:39
  • SQLNET.ENCRYPTION_SERVER=REQUIRED SQLNET.ENCRYPTION_TYPES_SERVER=(AES256) – Arnaldo Raxach Oct 1 '18 at 0:40
  • SQLNET.ENCRYPTION_CLIENT=REQUIRED SQLNET.ENCRYPTION_TYPES_CLIENT=(AES256) – Arnaldo Raxach Oct 1 '18 at 0:41
  • Encrypt the data correctly with that configuration, for example connection from my pc to the server and vice versa, I verify it with tcpdump, but it does not happen that way when I use dblinks ... in that case the packages I capture are seen in plain text, oracle gateway does not have any option to encrypt connections ... it's weird – Arnaldo Raxach Oct 1 '18 at 0:45
1

The solution that worked for me was to use Advanced Security, with netmgr or directly edit the sqlnet.ora by adding the parameters:

SQLNET.ENCRYPTION_SERVER = REQUIRED

SQLNET.ENCRYPTION_TYPES_SERVER = (AES256)

SQLNET.ENCRYPTION_CLIENT = REQUIRED

SQLNET.ENCRYPTION_TYPES_CLIENT = (AES256)

Once this is done it is necessary to restart the listener, for access to heterogeneous data base the sslmode = require parameter must be added in odbc.ini for postgresql, the ssl access must be previously configured in the postgres server and a registry with hostssl in the file pg_hba.conf ... I have not tried for sql server yet. Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.