I'm trying to create a linked server to an instance of MySQL. I've created a System DSN to the instance and that passes the connection test, but when I try to create a linked server using that data source, I get an error (specifically Cannot initialize data source object of OLE DB provider MSDASQL for linked server "MyServerName") The system error is 182, MS Sql Server error 7303. Screen shot below:

enter image description here

Below is a screen shot of the general settings (TEST_MYSQL is the name of the data source I've previously and successfully configured and tested):

enter image description here

I'm using the "use this security context" with a username and password that work in the data source name. Below is a screen shot of the server options.

enter image description here

I'm not sure what I'm missing or doing wrong, but this isn't working. I would assume that something is configured wrong, but the data source connects successfully using the same creds. Is there something missing that would make the data source connect fine but prevent the linked server using that data source from doing so? Please advise, thanks!

1 Answer 1


So after trying a ton of things with options in the driver, settings in the MSDASQL provider, etc. Replacing the MySQL ODBC driver with an older version worked immediately. This solved my issue. thanks!

  • I'm currently having the same issue. Do you remember which version you finally used? And do you have more informations about that? Thank you very much. Jun 5, 2019 at 12:17
  • downloads.mysql.com/archives/c-odbc This is the link for older archived versions, I don't 100% recall which I used, and that was at a previous employ, but it had to do with the fact that the MySQL version was an older version that the current drivers didn't play nice with. I want to say we ended with 5.1.x(?). That's probably not the complete picture, but hopefully enough to get you moving in the right direction. Jun 5, 2019 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.