I successfully generated the snapshot, but subscription is not working correctly. Either the synchronization takes too long to respond or it simply displays the text shown in below attached screenshot.

Here is the successful snapshot generation:

Snapshot generated

Screenshot for the synchronization status

It is only retrying and not giving the end result.

up vote 1 down vote accepted

Check the following things please:

  • Snapshot Agent shows as completed successfully and it has generated its files
  • Log reader agent is running and delivering

Right click on each service -> view details - that will help you get more info. Agents status

To add to the comments, check the subscription details: subscription details Go to each tab and see if there's any error. If all is good, they should all show green, running, with an action list of delivering transactions.

  • As the snapshot was generated successfully so it says completed but the subscription end is not working – dbadmin Oct 8 at 9:41
  • Is the log reader running correctly? Does it say it's delivering commands? – Marian Oct 8 at 9:43
  • Yes, i got stuck at this docs.microsoft.com/en-gb/sql/relational-databases/replication/… (View the synchronization status of the subscription) – dbadmin Oct 8 at 9:46
  • See the updated answer pls. How do the 3 tabs look at your end? Any messages/errors showing there? – Marian Oct 8 at 9:52
  • 1
    No worries, glad to help. Thanks on this site are send via those up/down arrows (up-votes for useful ones, down-votes for bad ones) and/or Mark as answer :-). – Marian Oct 8 at 11:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.