Using SQL server 2017 (14.0.3029.16) with Always On High Availability environment.

Getting error:

CImageHelper::Init () Failed load of symbol file with path = C:\Program Files\Microsoft SQL Server\MSSQL14..... Error Code 0xc0000004

There is nothing before or after this error and all I have to go by is a SPID. there is no set time, its happened once at 12:30AM and another time at 10:1 5AM.

I did some googling and there was one recommendation of reducing the MAXSIZE of the server memory. We have it set to 433,600 with 500,000 available.

How can I solve the problem and get rid of this error?

Additional information

  • Total RAM on the server is 500GB
  • Forced encryption is not enabled

Responses to comments

  • Anything in windows event log - app or system? Any mini dumps generated?

    Event viewer has nothing that correlates with those time frames but something I will have to review further because I do see some errors.

  • For mini dumps - just check select * from sys.dm_server_memory_dumps

    Nothing came back.

  • Let us continue this discussion in chat.
    – Kin Shah
    Oct 8, 2018 at 18:06
  • might be too early to tell, but i reduced my "Server Memory Options" down to 90% of whats available and knock on wood, the errors stopped. So in the above i said i had 433,600 being used but it was actually 483,600, brought it down to 453,600. didn't have to restart sql because the total used was only 400,000.
    – Tomasz
    Oct 12, 2018 at 13:34

1 Answer 1


I resolved this by navigating to

C:\Program Files\Microsoft SQL Server\MSSQL14.MSSQLSERVER\MSSQL\Binn

on the SQL Server and modifying two .ini files within the Binn folder. The first is sqlctr and the second is sqlagtctr.

Upon opening the files you will see that both contain




nested under [info].

By replacing [SYMBOLINSTALLPATH] with the fully qualified path of C:\Program Files\Microsoft SQL Server\MSSQL14.MSSQLSERVER\MSSQL\Binn and restarting the SQL service, I was able to get the issue resolved.

For example, the beginning file content should now look similar to the following:

symbolfile=C:\Program Files\Microsoft SQL Server\MSSQL14.MSSQLSERVER\MSSQL\Binn\sqlagtctr.h

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.