On a 2-node RAC we have enabled Automatic Memory Management. The advisor views indicate that increasing the buffer cache by 4 GB will half the physical reads, and we have 4 GB to give.

How must we do this? By increasing memory_target and letting Oracle grab more memory for the buffer cache? Or by explicitly setting a value for db_cache_size (which now is zero)?

1 Answer 1


You can set the value for db_cache_size, and the value you set for it will be considered the minimum value it can be with AMM enabled.

  • Thank you, so I guess that in order to not affect anything else, I should also increase the memory_target and memory_max_target, correct?
    – GID
    Oct 12, 2018 at 6:55
  • @GID If the current value of them does not allow the db_cache_size to be 4G (because let's say, memory_target=3G), then yes, of course. Oct 18, 2018 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.