13

I have just downloaded the latest Community Installer (5.5.27) along with the MySQL WorkBench (5.2.41). I clicked OK on all default settings on setup.

When I try to "Open a connection to start querying" on the WorkBench home page and chose "Local Instance MySql 55", I keep getting stuck on a never-ending "Opening SQL Editor" screen ("An SQL Editor instance for "Local Instance MySql 55" is opening and should be available in a moment")

Any idea on what could be wrong ?

EDIT : I am able to access it from command line and query it successfully. But still not from query editor.

4
  • Is the mysql service running? Have you tried the Local Administration from the Workbench? Aug 4, 2012 at 13:15
  • yes it is running, and I can access Server Administration for local MySQL55 on the WorkBench Aug 4, 2012 at 16:53
  • Then porblem lies with Workbench as you are able to query using command line client. Aug 6, 2012 at 5:44
  • Yes please see edit Aug 6, 2012 at 14:01

6 Answers 6

12

Thanks Mika, I tried your solution in workbench (5.2.41). It worked after I cleared the passwords in the vault (click Manage Connections) and restarted the WorkBench.

To clear passwords stored in the vault, I did the following:

  1. Open MySQL WorkBench the you will see the home page
  2. Click Manage Connection at bottom left corner.
  3. In Manage DB Connections, click Clear button besides Store in Vault...
  4. Close it and restart WorkBench.
  5. Double click Local instance mysql in home page, now you db will popup.
0
2

I don't know what happened. I launched a command window, it worked. Then I retried, after clearing the password vault, and it worked.

1

When the default "Local instance MySQL Router" was not working and clearing the password vault didn't resolve it, I ended up creating a new connection (same settings, credentials, etc...) and used the new connection instead. You can safely delete the original after you have determined the new connection is working for you.

Setup New Connection

0

For anyone who's problem not solved with these solutions, if you open Services, for me there were two services MySQL (running) and MySQL80 (stopped). I stopped MySQL and started MySQL80 and solved my problem immediatelly.

1
  • thta is not enough, if the service mysql is on automatic ´, it will statrt the next time after reboot, so you have to disable it too. and chekc if mnysql8 is on automatic start
    – nbk
    Apr 17, 2021 at 13:16
0

Don't panic, i also tried clearing passwords in the vault and all. But my problem didn't solve.

I started the MySQL installer and from there I ran the Reconfigure option for MySQL Server

Follow these screen shots to bring your instance back online.

MySQL Installer (Initial Screen)

MySQL Installer (Initial Screen) Select the Reconfigure option on the topmost entry for MySQL Server.

MySQL Installer | Type and Networking

MySQL Installer | Type and Networking Nothing to change here. Click on Next >.

MySQL Installer | Accounts and Roles

MySQL Installer | Accounts and Roles Add your password for the root account and click on Check button. When the password has been verified click on Next >.

MySQL Installer | Authentication Method

MySQL Installer | Authentication Method Leave the recommended option. Click on Next >.

MySQL Installer | Windows Service

MySQL Installer | Windows Service Nothing to change in this window. Click on Next >.

MySQL Installer | Apply Configuration

MySQL Installer | Apply Configuration In the summary windows click on the Execute button. The changes are applied to the system.

MySQL Installer | Apply Configuration (Finished)

MySQL Installer | Apply Configuration (Finished) In the summary window you will see everything with green tick marks if everything was applied correctly.

Do what I did and don't change any type of standard settings. Just follow the buttons/screens and that's it.

Now your MySQL Workbench will open without any issues. MySQL Workbench opens up

0

I also faced this problem when I manually changed the password and after I closed that session, when I restart it again, it hangs on the same page.

The solution which worked for me :

  1. Right click -> edit connection
  2. Enter the new password -> Test connection
  3. If it succeeds, click Store in Keychain and close
  4. Now double click the local instance - got opened

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.