0

I'm encountering the following error upon executing sudo service mongod start in terminal.

    mongod.service - MongoDB Database Server
   Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2018-10-18 12:43:22 ACDT; 7s ago
     Docs: https://docs.mongodb.org/manual
  Process: 3155 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=exited, status=100)
 Main PID: 3155 (code=exited, status=100)
      CPU: 22ms

Oct 18 12:43:22 david- systemd[1]: Started MongoDB Database Server.
Oct 18 12:43:22 david- mongod[3155]: 2018-10-18T12:43:22.736+1030 I CONTROL  [main] Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'
Oct 18 12:43:22 david- systemd[1]: mongod.service: Main process exited, code=exited, status=100/n/a
Oct 18 12:43:22 david- systemd[1]: mongod.service: Unit entered failed state.
Oct 18 12:43:22 david- systemd[1]: mongod.service: Failed with result 'exit-code'.

I am unfamiliar with this error, could anyone please suggest what the fix might be?

0

Fixed using this answer from another post:

Open /etc/mongod.conf and look for dbPath: /xyz/xyz

Use the following command to provide the rights to mongodb

sudo chown -R mongodb:mongodb /xyz/xyz

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.