0

Metabase currently imports the column names and tries to figure out the wording. This convention is fundamentally broken in my schema. For example, when it scans my PostgreSQL database it'll bring in the columns as,

As St Tre As Appoint Or Name First
As St Tre As Appoint Or Name Last
As St Tre As Name First
As St Tre As Name Last
As St Tre As Name Organization
As St Tre As Name Prefix Cd
As St Tre As Name Short
As St Tre As Name Suffix Cd
As St Tre As Per Sent Type Cd
As St Tre As Primary Phone Ext
As St Tre As Primary Phone Number

In reality they look like,

assttreaspersenttypecd   
assttreasnameorganization
assttreasnamelast        
assttreasnamesuffixcd    
assttreasnamefirst       
assttreasnameprefixcd    
assttreasnameshort       
assttreasstreetaddr1     

Where assttreas is a shorthand for "Assistant Treasurer". Is there any easy way to fix this or disable this "feature".

0

You can disable "Friendly Table and Field Names" in Admin -> Settings -> General:

enter image description here

After you do it, go to Databases -> your_db_name and trigger "Sync database schema now" and "Re-scan field values now" actions:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.