I connected as sysdba and tried below:

SQL> startup;

ORA-01506: missing or illegal database name


I tried multiple scenarios changing the Oracle_home and path variables but no luck.

These are my env variables:

c:\>echo %ORACLE_HOME%

c:\>echo %ORACLE_SID%

ndows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\ATI Technologies\A

Also, I tried to restart the services manually but no luck.

The Content of initXE.ora is:


I tried:

SQL> create pfile='C:\temp\initXE.ora' from spfile;

File created.

SQL> create spfile from pfile='C:\temp\initXE.ora';

File created.

SQL> startup;
ORACLE instance started.

Total System Global Area  217157632 bytes
Fixed Size                  2251776 bytes
Variable Size             159384576 bytes
Database Buffers           50331648 bytes
Redo Buffers                5189632 bytes
ORA-00205: error in identifying control file, check alert log for more info

Still getting an error.


2 Answers 2

$ oerr ora 1506
01506, 00000, "missing or illegal database name"
// *Cause:  No db_name INIT.ORA aprameter was specified.
// *Action:  The database name must be given in the db_name
//          INIT.ORA parameter.

Your ORACLE_SID is XE. When you issue startup, your process looks for a file %ORACLE_HOME%\database\spfileXE.ora, or if it does not exist, then %ORACLE_HOME%\database\initXE.ora.

You get the above error when the db_name parameter is missing from them.

You can edit initXE.ora with any text editor and add the missing parameter: *.db_name='XE'. spfile should not be edited directly, first create pfile from it:

create pfile='C:\temp\initXE.ora' from spfile;

Add the missing parameter to `C:\temp\initXE.ora', then create the spfile from it:

create spfile from pfile='C:\temp\initXE.ora';

After that, try startup again.

ORA-00205: error in identifying control file, check alert log for more info

That is a completely different error, meaning the files defined in the parameter control_files are inaccessible.

  • So, what could be the solution for accessing the control_files? Nov 1, 2018 at 15:43

control file parameter is missing in your initXE.ora file.

Search for control file locations (control01.ctl and control02.ctl) in oracle base directory.create new ora file myXE.ora(any name is fine) with just two lines


next start database with pfile

startup mount pfile='c:\temp\myXE.ora

If no errros from above step

alter database open;
create spfile from memory;

If above steps did not resolves your issues meaning either control files missing or corrupted you need to recreate control files from alert logs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.