I want to import one of my schema "vvs1" to r&d database with content=metdata_only. expdp works perfect but when i am going to import on r&d server it takes tables original size.

for example:- I have 1 table vvs.xyz with size of 10 GB. i am taking structure backup only. now import on r&d server it creates a table structure with 10 GB size. i want only table with default size while created.

expdp syntax:

expdp vvs/1 full=Y CONTENT=METADATA_ONLY directory=DATAPUMP_DIR dumpfile=full.dmp logfile=full.log KEEP_MASTER=Y

impdp syntax:

impdp vvs/1  CONTENT=METADATA_ONLY directory=DATAPUMP_DIR dumpfile=full.dmp logfile=full_impdp.log schemas=vvs

main database :-Oracle Database 12c Standard Edition Release - 64bit Production

r&d database:- Oracle Database 12c Enterprise Edition Release - 64bit Production

  • It will use the init and next segment sizes when creating the table. You will have to create it manually before you do the import.
    – sandman
    Commented Nov 16, 2018 at 12:08
  • Just out of interest, are you really using standard in prod, and EE in R&D? Commented Nov 19, 2018 at 11:58
  • yes, i did this only on dev & testing server only
    – Ray
    Commented Nov 19, 2018 at 13:10

1 Answer 1


Typically caused by the segment attributes of the tables.

You can use TRANSFORM=SEGMENT_ATTRIBUTES:N, so the tables will be created with default options.

You can use TRANSFORM=SEGMENT_CREATION:N as well, so your segments will not be created at all, unless deferred segment creation is disabled in your database.



  • thanks a lot @Balazs Papp, from this parameter it works proper
    – Ray
    Commented Nov 19, 2018 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.