I'm getting the error below while creating an AG listener in SQL Server.

Ensure that the network adapters for dependent IP address resources have access to at least one DNS server. Alternatively, enable NetBIOS for dependent IP addresses.

The user has full privileges and it can create a computer object and a DNS entry successfully.

Please help me to fix this issue.

closed as off-topic by hot2use, LowlyDBA, McNets, Mr.Brownstone, Vérace Dec 9 at 23:33

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – hot2use, LowlyDBA, McNets, Mr.Brownstone, Vérace
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Are you able to share the cluster log? – Sean Gallardy Dec 4 at 21:51
  • 000005bc.000026b4::2018/12/04-15:42:11.578 WARN [API] s_ApiOpenNodeEx: Node TEST3 failed, status = 5042 0000021c.000023e0::2018/12/04-15:42:13.587 WARN [RES] Network Name <AG_LISTENER>: NetName::Dns::PingNameInternal: (11010)' because of '[cxl::Pinger-"LISTENER"] Could not send IPv4 echo.' – Sathish Dec 5 at 5:25

First, make sure the cluster's user account can create computer objects in Active Directory. See this link for the specific steps you need to do in Active Directory Users and Computers to grant the permissions. By default, the cluster does NOT have the rights it needs and the AG wizard doesn't really do anything to warn you or to grant those rights for you.

  • It has permission and i can see newly created object(ag listener name) – Sathish Dec 4 at 18:52

This server is in hyper-v and Always on listener creation use hyper-v host IP's send packets to DNS server. Once we enabled access in network level, The issue got fixed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.