I am having an issue with filestream and accessing the files. From the server itself I can access the files in the filestream folder when browsing direct on that computer. However when I try to browse the filestream UNC path on that server using localhost or from another computer it says incorrect function / don't have permission to view the share.

This was working fine, then Microsoft updates happened. We have since even upgraded to SQL 2017 and it is still not working. I have ensured that the owner of the folder is set to the same account as the service start up account. The permissions are set to allow me full control over that folder so I should be able to access it as well. Everything I have found online I have tried to no avail. Does anyone have any ideas?

  • Just to make sure: You did enable the filestream options in SQL Server Configuration Manages and also with sp_configure (set to 2)? – Tibor Karaszi Dec 6 at 10:42
  • I know configuration manager is set to enable, where is sp_configure? I know inside SQL server properties it is set to full. The strange part is when I ran the query to see what level it was set to, it listed about 7-9 instances of the database and only one of them had access. – Jesse Pearson Dec 6 at 13:51
  • 1
    EXEC sp_configure 'filestream' I don't really follow what yo mean by seeing several instances of database, so if you want to elaborate (for instance share "that query"). – Tibor Karaszi Dec 6 at 15:01
  • What is the specific error message you are getting? – Kevin3NF Dec 6 at 16:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.