0

I tried to set up a linked server via ODBC connection in SQLServer. It seem to connect but showed all the caches as empty names in SSMS. Also I couldnt get a select query to work.

Has anybody had any luck with doing this? If so.. How did you write the select statement?

migrated from stackoverflow.com Dec 15 '18 at 5:56

This question came from our site for professional and enthusiast programmers.

  • Also be sure to use Apache Ignite 2.7 as there are improvements to ODBC. – alamar Dec 17 '18 at 11:13
  • Thanks, just updated that today from 2.6. I'll see if that helps tomorrow. – W. Sprague Dec 18 '18 at 2:22
0

Maybe you don't have tables for your caches. By default, Apache Ignite will not create tables in its caches - i.e. they are not mapped to SQL but work in key-value mode.

There are basically three options to make tables in Ignite - CREATE TABLE, Query Entities, and Indexed Types + annotations.

You can validate it by connecting to cluster with built-in sqlline utility and then issuing !tables command.

  • Yea, I defined and created persisted cache objects.. my error may be they are stored by binary serialization, that just occured to me. I'll try to create tables via "create table" or non binary and see what happens. – W. Sprague Dec 18 '18 at 2:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.