0

The machine config is Windows Server 2012, 64 Bit SQL Server 2016, and SQL Server Management Studio 2017. When I use SQL Server Configuration Manager to enable filestream, it gives me an error that I do not know how to get around.

There was an unknown error applying the FILESTREAM settings. check the parameters are valid. (0x80041008)

  • Windows and SQL Server both are 64-bit? – CR241 Dec 17 '18 at 18:22
  • see this SO question – Kin Shah Dec 17 '18 at 18:41
  • 1
    I've removed the image in your question because it only shows the same error message you have pointed out in your text. You can add it again following this link and clicking rollback button of any of the other edits. – McNets Dec 17 '18 at 20:37
1

Root Cause?

During October we installed SQL Server 2016 on the server – but the desktop icons were still set to SQL Server 2017. When I used the 2016 Configuration Manager, it seemed to work.

Multiple versions installed on TEST Server:

Multiple SQL versions installed on test server

Configuration manager on TEST Server with Configuration Manager 2017:

SQL 2017 Configuration Manager

SQL Server Version on TEST Server:

SQL Version on Test Server
Using SQL Server 2016 Configuration Manager:

enter image description here

So basically we were running the wrong version of configuration manager. Also we did a server restart. When I had previously tried to configure it on both 2016, 2017 configuration manager, it didn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.