2

I have a few servers where I see a blue question mark on the sql server service, as per the picture below.

enter image description here

This is the solution:

Enabling these Windows Firewall rules did the trick for me

Windows Management Instrumentation (WMI-In)

Windows Management Instrumentation (DCOM-In)

Is there a way I could achieve this via powershell?

1 Answer 1

7

You would use the Enable-NetFirewallRule cmdlet:

Enable-NetFirewallRule -Name "WMI-WINMGMT-In-TCP", "WMI-RPCSS-In-TCP"

In order to find the relevant rule names (in order to enable it), you can search existing firewall rules by name by using the Get-NetFirewallRule cmdlet, for example:

Get-NetFirewallRule -Name "*WMI*"

This uses wildcards to final all the rules that contain "WMI" as an example.

3
  • Small note, you can shortcut the command by providing both names together. So Enable-NetFirewallRule -Name 'WMI-WINMGMT-In-TCP','WMI-RPCSS-In-TCP' would have the same effect.
    – user507
    Commented Dec 31, 2018 at 16:56
  • @ShawnMelton Thanks! I don't use PowerShell super often these days, and always forget exactly what syntax to use for passing lists like that. So I just default to multiple commands =) I've updated the answer. Commented Dec 31, 2018 at 17:08
  • Oh, it works either way. Some prefer to use multiple for readability when they are just glancing....as long as it gets the job done.
    – user507
    Commented Jan 1, 2019 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.