0

I'm doing MYSQL Replication for the first time.

Master mysql version: mysql Ver 14.14 Distrib 5.1.52, for pc-linux-gnu (i686) using readline 5.1

Slave Version: mysql Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86_64) using readline 5.1

I already make a connection of master to slave but when an insert query execute, it shows Error 'Unknown Collation: '2048' on query. Default database is 'master'.

Already check for answers in google but no solution was made for 2048. What should I do to fix it?

error query: Error 'Unknown collation: '2048'' on query. Default database: 'master'. Query: 'INSERT INTO DOCTORS_LOG(cno,empno,name,dept,sex,age,civilstatus,empstatus,datehired,complaints,diagnosis,dte,personnel) values (cno,'69408','JEFFREY MONTERON','PRODUCTION/MACHINERY ENGINEERING','MALE','20','SINGLE','Contractual','2017-09-18','cold x 2 days ','A> AURTI P> dynatussin 1 cap PO tid for 3-5 days',(Select sysdate()),'Dra. Joyce Guanin')' 1 row in set (0.00 sec)

  • Can you provide the INSERT statement and the SHOW CREATE TABLE on both Master and Slave. (They should be the same, but want to check.) – Rick James Jan 3 at 17:51
  • 1
    but... It is past time to upgrade; 5.1 is ancient history. – Rick James Jan 3 at 18:02
  • Note that you appear to be using mysql -v to get the server version, which is incorrect. This only gives you the client library version. Use mysql -e 'SELECT @@VERSION;' to identify the actual server versions. – Michael - sqlbot Jan 4 at 0:34
  • 1
    @EarvinNillCastillo the slave must be the same version of the master, or up to one release series newer. 5.1.x master works with 5.1.y slave where y >= x; 5.1.x master works with any 5.5.z slave. – Michael - sqlbot Jan 16 at 12:15

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.