0

This question already has an answer here:

I have just restored a backup taken from xtrabackup (only for testing, so not critical luckily), and I am getting the following error:

InnoDB: Error: log file ./ib_logfile0 is of different size 0 125304832 bytes than specified in the .cnf file 0 262144000 bytes!

So I updated my my.cnf file to match this value:

[mysqld]
. . . 
innodb_log_file_size = 125304832

But I am stil getting an error:

log file ./ib_logfile0 is of different size 0 125304832 bytes than specified in the .cnf file 0 124780544 bytes!

But my my.cnf file is now set to 125304832 bytes so why does MySQL still think it is only 124780544 bytes?

marked as duplicate by Rick James mysql Jan 8 at 5:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • How did You restore Your backup? Have You prepared it before? percona.com/doc/percona-xtrabackup/2.4/backup_scenarios/… – Marcin S. Jan 7 at 12:24
  • if you can provide backup and restore logs in pastebin or some other method that would be great. try using the same mysql cnf file settings on the restored backup during startup – jerichorivera Jan 7 at 13:14
  • It was prepared correctly, I have used the same process various times before to restore backups, without issue. The cnf file, should have been the same as on the server that I backed up, which has always worked in the past, so I'm not sure why the ib_logfile0 file is the wrong size, – IGGt Jan 7 at 13:30
  • Have You tried restoring without ib_logfiles? Same method as used for changing logfiles size? – Marcin S. Jan 7 at 14:28
  • That results in Cannot initialize created log files because data files are corrupt, or new data files were created when the database was started previous time but the database was not shut down normally after that.. I think that maybe there is some issue with the backup itself so I'll try a different one and see what happens. – IGGt Jan 7 at 14:39

Browse other questions tagged or ask your own question.