0

I upgraded to MySQL 8.0.13 and tried to add a new field using ALGORITHM=INSTANT but got the following error:

Error Code: 1845. ALGORITHM=INSTANT is not supported for this operation. Try ALGORITHM=COPY/INPLACE

Then I recreated the same table in MySQL 8.0.13 and tried to add the same field using ALGORITHM=INSTANT and it works!

Will this new feature of MySQL (ALGORITHM=INSTANT) only work on newly created tables in the upgraded version?

  • 1
    This might be something very specific to the table you are modifying and how it is benign modified. Please include 'SHOW CREATE TABLE {tablename}' and your 'ALTER TABLE' SQL. – danblack Jan 22 at 5:41
  • 1
    I tested with several tables even with a small table having a single field but got the same result. I suspect it is a bug. bugs.mysql.com/bug.php?id=92194 – jithin giri Jan 22 at 6:04
  • 1
    And that bug says "fixed in 8.014". – Rick James Jan 22 at 16:18
  • Well researched @jithingiri. Feel free to provide this as an answer. Given 8.0.14 was released a few days ago I suspect you're on an upgrade path. Hope it works for you. – danblack Jan 23 at 0:21
  • sure @danblack .. – jithin giri Jan 23 at 6:27
1

According to my research, this is a bug

https://bugs.mysql.com/bug.php?id=92194

which is explaining " For ALTER TABLE, ALGORITHM=INSTANT was incorrectly rejected on tables created in a MySQL version prior to 8.0.12 " " Fixed in 8.0.14. "

I didn't tested it with 8.0.14. I will post here the results once I tested it with 8.0.14.


[update]

Tested it in 8.0.14 and it works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.