2

Problem

We are running a SQL Server 2014 SP3 CU1 on Win 2016. After a each reboot of the host the SQL Server service won't start automatically. It always results in the following error messages.

The service is configured to start automatically.

SQL Server log:

Error: 17190, Severity: 16, State: 1. Initializing the FallBack certificate failed with error code: 1, state: 20, error number: 0.

Unable to initialize SSL encryption because a valid certificate could not be found, and it is not possible to create a self-signed certificate.

Error: 17182, Severity: 16, State: 1. TDSSNIClient initialization failed with error 0x80092004, status code 0x80. Reason: Unable to initialize SSL support.

TDSSNIClient initialization failed with error 0x80092004, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors.

Error: 17826, Severity: 18, State: 3.

Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.

Error: 17120, Severity: 16, State: 1.

SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

Workaround

I could solve the issue temporarily in the following way:

  1. connect via RDP to the host and login with the service account name
  2. open the SQL Server Configuration Manager
  3. start the SQL Server service

Unfortunately I can't start the service when I login with my personal login to the host. It results in the same error mentioned above.

Ideas

We already tried to delete the profile of the SQL service account. It doesn't solved the issue.

We also thought about space problems, but the host has more than 20% (> 50GB) free space available for each used drive.

What could be the issue with the certificate? How and what I have to check?

  • Service account is part of local admin ? Check this to see if it helps in your case blogs.msdn.microsoft.com/john_daskalakis/2014/10/15/… – Kin Shah Jan 24 at 14:23
  • If this error does not occur when logging in as the service account, then that proves it is not a space issue. My guess is that this is a permissions issue, possibly registry permissions. Is the service account the one that was specified when installing the instance, or was it changed after installation? – Solomon Rutzky Jan 24 at 15:27
  • @kin jup, it's part of the local admin group. – Robert Jan 24 at 15:41
  • @solomon-rutzky that's a good question. I need to check the bootstrap files. Could it be related as the service account is now part of the local admin group? – Robert Jan 24 at 15:42
  • @Robert not sure if it is related. if the account wasn't part of the local admin group originally, you can always try taking it out and seeing if that makes any difference. I don't think it would, but couldn't hurt to try. If the service account was changed, then maybe it points to a different certificate store now? – Solomon Rutzky Jan 24 at 15:49
1

TDSSNIClient initialization failed with error 0x80092004, status code 0x1.

// MessageId: CRYPT_E_NOT_FOUND
//
// MessageText:
//
// Cannot find object or property.
//
#define CRYPT_E_NOT_FOUND                _HRESULT_TYPEDEF_(0x80092004L)

What could be the issue with the certificate?

The certificate is corrupt or otherwise unusable in its current state, or lacks a private key component (either corrupt or account isn't able to access).

How and what I have to check?

A quite easy and quick check is to open up the MMC Certificates Manager console (certmgr.msc) and right-click on the certificate, choose "all tasks", "Manage Private Key", which will most likely result in an error stating that the key doesn't exist or some other random error message.

If you don't receive an error, then make sure the SQL Server Service account has permissions to read the private key (also on the manage private keys screen).

If you get an error, then SQL Server can't read the private key which means it's going to fail to start up. Thus, either remove the SSL Certificate from use for SQL Server, restore it from a good backup, or generate and use a new one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.