1

I'm trying to migrate the data at my company from Excel to mySQL so I'm very new at this. I just installed the latest mySQL package via the standard installer and when I try a new connection (I'm trying to get through the mySQLTutorial) the error pops up:

MySQLWorkbench.exe - No disk

There is no disk in drive. 
Please insert disk in drive \Device\Harddisk\DR2

My setup for the new connection is as follows:

Connection name: local
Connection method: Standard (TCP/IP)

Hostname: 127.0.0.1
Port: 3306
Default schema: ""

Anyone have any ideas? I'm completely at a loss here...

  • So, I assume you are working on a Windows platform? – Mark Stewart Jan 29 at 16:53
  • My bad, yes I'm working with Windows 7 64bits – FranciscoRZ Jan 29 at 18:04
0

Did you install that on network share? Please try reinstall only workbench using this package https://dev.mysql.com/downloads/workbench/ and use default location c:\program files .... Maybe you didn't install MySQL Workbench Windows Prerequisites. You can find links on the same download page.

Regards, Marcin

  • Marcin, Thanks for taking the time to answer. The entire MySQL installation is on my C:/ drive. In my installed programs, I've got Microsoft .NET Framework 4.7.2 and Microsoft Visual C++ Redistributable 2005/2008/2010/2012/2013/2017 in both x64 and x86. I've even tried repairing the Microsoft Visual C++ 2017 Redist but it had no effect. When I tried installing Microsoft Visual C++ 2015 Redist it failed because it already detected the program on my PC (I'm guessing this has something to do with the other versions I have). Do you think I actually need to downgrade my redist? – FranciscoRZ Jan 31 at 9:21
0

I fixed this by changing the path of the configuration file from

%ProgramData%\MySQL\MySQL Server 5.5\my.ini

to

C:\ProgramData\MySQL\MySQL Server 8.0\my.ini

in MySQL Workbench.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.