0

This is the error I have been getting on my RMAN notifcations on my backup jobs for the last day or so. The title is exactly how the message is formatted.

~~~End Step Output/Error Log~~~
Error Log:BackupOp
error writing input to commandERROR: Invalid username and/or password

~~~End Step Output/Error Log~~~

I only have 2 backup jobs and both are affected by this. Not sure how much information here is useful but what I have been looking at is the SYS account the jobs are using is not locked out.

select account_status from dba_users where username = 'SYS';

ACCOUNT_STATUS                  
--------------------------------
OPEN

The emagent.trc log is showing this pair of lines for every backup job since the first one failed.

2019-02-06 23:44:26,791 Thread-14472 ERROR command: failed to write to stdin of process 6228: (error=232, no message available)
2019-02-06 23:44:26,791 Thread-14472 ERROR command: nmejcc_feedInput: received -11 from process write

Restarting the DBConsole service has no affect and the errors persist.

I can manually run full and archivelog backups just fine as sysdba. I see no reason to blame RMAN since I can run the backup rman scripts just fine. I think this is just an EM issue.

  • Driving me nuts.. I was told I should do an emergency shut down of the server and reboot. Which accomplished nothing. – Matt Feb 7 '19 at 20:47
0

I got more information when I tried to rebuild another backup job in EM using the credentials. I got the same error when I tried to use the same Host Credentials I got the same Invalid username and/or password error on the page.

I could not find anything authoritative on the subject but I read a list of prerequisites from this Oracle Community thread. Paraphrased..

The user needs to be member of the ora_dba group and have local security privilege Log on as a batch job.

In my case the former was true but the latter was false. An admin on the team was "cleaning" up pcs in an OU and moved this server into another with different GPOs applied.

So in the end, I gave the local account, used as Host Credentials, Log on as a batch job rights and the backup jobs continued to work again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.