0

I have just installed the MariaDB backup tool based on Percona Xtrabackup, Mariabackup, on my CentOS 7 system with MariaDB v10.1. However, when I try to test using this tool, it fails immediately complaining about an unknown argument.

I tried running this command as a full backup, as a full backup using the --xbstream option to pipe it through gzip, and as a full backup using gzip and OpenSSL. I also tried GPG with gzip.

Here are the commands I've tried:

With gzip/openssl:

mariabackup --user=root --password= `cat /etc/psa/.psa.shadow ` --backup     --stream=xbstream | gzip | openssl  enc -aes-256-cbc -k password123 >     backup.xb.gz.enc

with gzip/gpg:

mariabackup --user=root --password= `cat /etc/psa/.psa.shadow ` --backup --stream=xbstream | gzip | gpg -c --passphrase password123 --batch --yes -o backup.xb.gzip.gpg

With gzip:

mariabackup --user=root --password= `cat /etc/psa/.psa.shadow ` --backup --stream=xbstream | gzip > backup.xb.gz

And just straight up:

mariabackup --user=root --password= `cat /etc/psa/.psa.shadow ` --backup --target-dir=/root/sql_dumps/

And here's the output:

Info: Using unique option prefix 'backup' is error-prone and can break in the future. Please use the full name 'backup_encrypted' instead. mariabackup: Error: unknown argument: '$AES-128-CBC$GzzuTl0rBKRyCngfmWSypg==$JAmMp9hcbIQ/MTrzqCQ8eWIFQGixpUjZ7ESQqNLfuJM='

  • Something fundamental to this is broken on my machine. I simply used the yum tool to install MariaDB-backup and this was the result. It appears I'll have to find a new solution, which is a shame because this should work out of the box. – Matt Aikens Feb 12 at 15:45
0

I'm pretty sure this error was caused by supplying the wrong username. After I resolved that, the error went away and the backup initiated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.