0

When i select table with view/edit data => all Rows then i try to refresh table for newly updated data in table from object tab. it seems it's not working.this works perfectly in pg-admin 3 but in pg-admin 4 it seems it's not working at all.is this an issue in pg-admin 4 or i configured something wrong when i installed i followed all the instructions in docs on how to install it on Ubuntu exactly.can someone help me on this matter or explain it ?

New contributor
sasha romanov is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

Right click on the table and choose 'refresh' from the drop down menu. Or better, right click on the database selected and choose 'refresh' from the drop down.

  • I've tried both the first one it's not working , and the second one only updates the database i mean on the left side, but the opened mini window (query editor) it doesn't refresh , i have tried both. i don't know what the issue here , i'm using pg-admin 4 browser client – sasha romanov Feb 12 at 8:12
  • PostgreSQL works on Snapshot principle. The query window will never get refreshed. But why do you want to refresh the query window? Its just an editor for queries to run – devilboy477 Feb 12 at 8:14
  • when i'm testing on db sometimes i want to know if something is updated correctly , so every time i open new window , it's doable but painful sometimes , i thought there could be a solution for that – sasha romanov Feb 12 at 22:21
  • You can always select highlight the query and run it, if the changes persist it will definitely throw an existing error. But yeah, something of the sort you are looking for does not exist. – devilboy477 Feb 13 at 5:32

Your Answer

sasha romanov is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.