0

Database version is 12.1.0.1. We have one primary database and two physical standby database and dataguard also configured.

Dataguard sync is fine working between primary and physical standby.(No lag)

While checking the status of standby database by using DGMGRL getting below error

DGM-17016: failed to retrieve status for database "xxx_x" (xxxx_x - standbydbname) ORA-16706: Data Guard broker worker process not available

  • How did you configure the standbys ? put dgmgrl commands here – Sergiu Velescu Feb 14 '19 at 14:42
  • DGMGRL> show database verbose 'ABC_D' Database - ABC_D Role: PHYSICAL STANDBY Intended State: APPLY-ON Transport Lag: 0 seconds (computed 1 second ago) Apply Lag: 0 seconds (computed 1 second ago) Apply Rate: 499.00 KByte/s Real Time Query: OFF Instance(s): ABC .. .. .. Database Status: DGM-17016: failed to retrieve status for database "ABC_D" ORA-16713: the Data Guard broker command timed out – ram kumar Feb 15 '19 at 8:34
  • DGMGRL> show configuration; Configuration - Dataguard_ABC Protection Mode: MaxPerformance Databases: ABC_P - Primary database ABC_F - Physical standby database ABC_D - Physical standby database Error: ORA-16810: multiple errors or warnings detected for the database Fast-Start Failover: DISABLED Configuration Status: ERROR – ram kumar Feb 15 '19 at 8:34
  • Please find above, standby redo log creation done by alter database add standby command – ram kumar Feb 15 '19 at 8:35
  • Check if "ALTER SYSTEM SET dg_broker_start=TRUE SCOPE=BOTH;" on all environments, also check if no firewall betwen servers, read once again community.oracle.com/docs/DOC-1007327 – Sergiu Velescu Feb 16 '19 at 7:45
0

Thanks for comments for my doubts.

As now I have found a root cause and fix. Please find a fix:

The Broker is killing the RSM0 process and restarting it because of an internal timeout that is too low. This can happen even in network choke condition also. Please provide what the OperationTimeout is set to. DGMGRL> connect sys/ DGMGRL> show configuration OperationTimeout;

SOLUTION Increase the OperationTimeout or apply the patch. If this shows low 30-120, then set it higher, up to 600 (10 mins) :

DGMGRL> EDIT CONFIGURATION SET PROPERTY OperationTimeout=600;

Configuration - Dataguard_ABC

Protection Mode: MaxPerformance Databases: ABC_P - Primary database ABC_F - Physical standby database ABC_D - Physical standby database

Then works fine.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.