5

I'm guessing .NET Framework 3.5 is still needed to use Database Mail with SQL Server 2017? As I had to include this on my SQL Server 2016 installs on Server 2016 not that long ago.

I was unable to find a definitive answer via the web, surprisingly, maybe it goes unsaid.

7

No, it is not required for SQL Server 2017. The issue with Database Mail not working was fixed in 2016 SP1 CU2, and 2016 RTM CU2: FIX: SQL Server 2016 Database Mail does not work on a computer that does not have the .NET Framework 3.5 installed or stops working after applying SQL Server update

I know of several SQL Server 2016 and 2017 systems that are installed without .NET 3.51, and Database Mail is working fine.

Note that .NET Framework 3.5 was not included in Hardware and Software Requirements for Installing SQL Server, and that the SQL Server 2016 and SQL Server 2017 view of this page is the same. The Database Mail issue was considered a defect in SQL Server 2016 and was fixed accordingly.

  • Great, thanks for the clarification, yes I recall the dubious CU for SQL 2016 that broke database mail, so I ran around verifying that .net 3.5 was installed. Good times. – Eric Swiggum Feb 25 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.