I have downloaded Oracle XE 18c for Windows 64 bit, and tried to install it on a Windows 10 machine. I checked the SHA-256 checksum and it's correct.

The installation starts fine, but when it's copying new files it suddenly says "Rolling back installation", then ends and there's no error log to look at (there's no even C:\Program Files\Oracle folder, where Oracle error logs are stored). Any ideas?


2 Answers 2


System Requirements

Oracle Database XE for Windows x64 is supported on the following operating system versions:

  • Windows 7 x64 - Professional, Enterprise, and Ultimate editions
  • Windows 8.1 x64 - Pro and Enterprise editions
  • Windows 10 x64 - Pro, Enterprise, and Education editions
  • Windows Server 2012 x64 - Standard, Datacenter, Essentials, and Foundation editions
  • Windows Server 2012 R2 x64 - Standard, Datacenter, Essentials, and Foundation editions
  • Windows Server 2016 x64 - Standard, Datacenter, and Essentials editions

Home edition is not supported for Oracle databases and is known to have issues, like here:

Oracle 11g setup closes without errors on pre-requisite check


I had the same issue and I solved it. I was using this file to install XE Database: "Oracle Database 18c Express Edition.msi", but actually you should use "setup.exe", which installs prerequisites first and than runs "Oracle Database 18c Express Edition.msi"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.