I exported the dump using EXPDP command. After exporting I dropped the user and the associated tablespaces by logging is as / AS SYSDBA.

Then I re-created the User and the Tablespaces. Then I imported the dump using IMPDP. After importing I tried logging in with the re-created user and tried to query a table. And I got the following error.

ORA-01115: IO error reading block from file 5 (block # 326667)

ORA-01110: data file 5: '/data01/test/TBS_MYTBS_01.dbf'

ORA-27091: unable to queue I/O

ORA-27072: File I/O error

Additional information: 4

Additional information: 326666

Machine Details : Sun Solaris Oracle Version : Oracle10g

Could someone help me in resolving the error?

  • Voted to migrate to DBA.STACKEXCHANGE where hopefully you'll get a good answer.
    – Ollie
    Aug 24, 2012 at 8:15

1 Answer 1


Looks like a serious error. What is writte in the alertlog file? First thought is that the file is damaged. How exactly did you drop the tablespace[s]? how exactly did you perform the export? how exactly did you re-create the tablespace[s]? how exactly did you re-create the schema? how exactly did you perform the import? You should have dropped them using

drop tablespace X including contents and datafiles;

This would have taken care for cleanup of the old tablespaces. I also expect that you would have gotten errors during the import. When messing with databases and tablespaces, a little dba training would be very good. For 10g start here Oracle® Database 2 Day DBA 10g Release 2 (10.2)

and yes, this is more a dba question and task than for a developer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.