I'm really new to MariaDB and I need to set up encryption at rest. I'm running MariaDB 10.3 on Windows Svr 2012R2.

I have created a key and added the following to my config file (my.ini)

file-key-management-filename = "C:/MariaDB/data/keys.txt"

The service starts fine. However when I go to open the MySQL Client I get the following error:

C:\Program Files\MariaDB 10.3\bin\mysql.exe: unknown variable 'plugin-load-add=file_key_management.dll'

The dll is present and in the plugin-dir location specified in the config file.

Can anyone help me please?

  • same to me. there is no clear manual or help guide what should you do in that case and MariaDB manual is broken. i was able to find tickets on their JIRA about that kind of issue and all that they are doing is just saying 'yes yes we will fix everything' Commented Mar 20, 2019 at 13:37
  • can you share your complete my.ini? plugin-load-add is an option only the server binary understands, so it should be in the [mariadb], [mysqld] or [server] section only, and the client tools should never really see it. But here the command line client binary complains about it, so it seems to be in one of the config file sections it actually does read, like [client], [client-mariadb] or [client-server]. Could it be that you just added the encryption settings at the end of the .ini file and not in the correct section? Commented Jul 25, 2022 at 10:11

2 Answers 2


Hard to tell what went wrong here without seeing the full my.ini file, but the most likely cause would be that the encryption settings were just added to the end of the file, and so ended up in the [client] section instead of the [mariadbd] or [server] section where they actually belong.

So when starting the command line client it read the respective configuration sections, and stumbled across options that only make sense to the server process, but are unknown to the client programs.


mariadb from version 10.3 use other command in config: [mariadb] plugin_load_add = file_key_management like show in here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.